ProjectsForce February 23, 2025 Release Notes
ProjectsForce February 23, 2025 Release Notes
February 20, 7:11am
February 20, 7:11am
ProjectsForce Release Notes – New Feature Enhancements & Fixes
We are excited to introduce a series of powerful enhancements and fixes to ProjectsForce, designed to improve customization, reporting, scheduling, and overall user experience. These updates provide greater flexibility, better data visibility, and a smoother workflow for managing projects.
🚀 New Features & Enhancements
Custom Audit Log Reports with EPA Lead Details
ProjectsForce now allows company administrators to create customized audit log reports, providing deeper insights into project activities, technician details, and compliance with EPA regulations.
New Enhancements:
- A new Audit Log menu is now available under Company Configuration > Additional Features > Project Management & Linkage.
- Administrators can create, edit, or delete multiple custom audit reports.
- Reports can include specific columns from two modules:
- Project Details
- Project Technicians
- Users can adjust column positions and update data dynamically, ensuring real-time reflection of changes.
- EPA Lead Compliance: Additional fields related to EPA compliance, including lead test results and lead-certified technicians, are now available.
📑 Lead Owner (Salesperson) Details on Quote Preview
To improve customer communication, CRM Quotes now display lead owner (salesperson) contact details on the Quote Preview, replacing generic company-level footer information. This allows customers to directly contact the assigned sales representative for assistance.
💰 Quote Calculation Enhancement – Revenue Amount from Item Master
A major enhancement to CRM Quotes ensures that revenue calculations now automatically pull values from the Item Master instead of relying on manually entered retail prices. This improvement enhances accuracy and consistency in financial calculations.
🛠️ Capture Multiple EPA Lead Test Results
- Users can now log multiple EPA lead test results within the EPA Lead Tab.
- Each test entry captures:
- Test Result (Positive/Negative)
- Kit Manufacturer
- Location Tested
- For Lowes Jobs, if multiple tests are conducted, these details will be automatically transmitted via API integration.
📅 Project-Level Schedule Date Removal on Technician Deletion
- If a schedule-type technician is removed, the Schedule Start and End Dates will now also be cleared at the Project Level.
- Previously, only technician-level details were removed while project-level dates remained, causing inconsistencies.
👷 Technician Assignment Rules for Hidden Line Items
- If a line item is marked “Hide from All Technicians”, the system will no longer assign a technician to that item.
- If an item already has an assigned technician and is later set to “Hide from All Technicians”, the system will:
- Remove the assigned technician
- Exclude labor cost calculations for that item.
🔍 Improved Project Description Readability
A new hover pop-up is now available for project descriptions, ensuring that users can read full details even when the text exceeds available space.
📱 Restrict Document Templates from Mobile View
A new setting allows admins to restrict specific document templates from appearing on mobile devices.
- A new “Hide from Mobile View” checkbox is available for all document templates.
- If enabled, technicians will not see the document on their mobile devices.
- Admins can still override this restriction for specific jobs using the “Visible to Technicians” option.
🎨 UI & Performance Upgrades
Phase 1 of our UI enhancements is now live, improving user experience and system performance in key areas:
- Billing Tab
- Email Tab
- SMS Tab
- Issues Tab
- Activities Tab
- Time Management Tab
🐞 Bug Fixes & System Improvements
⚠️ Multiple Confirmation Popups
- Resolved an issue where users encountered duplicate confirmation popups in User Management, Project Details, and various other screens.
❌ Improved User Experience for Discarding Changes vs. Deleting Rows
- The “X” (Close) icon will now discard changes instead of deleting an item.
- The Trash icon will now be used exclusively for deleting items, with a confirmation prompt.
📆 Project Schedule Dates No Longer Update from Tentative Technician Edits
- When users modify tentative schedule dates for a technician, the project-level Schedule Start and End Dates will no longer be updated automatically.
📝 Notes Pop-Up Now Closes Properly
- Fixed a bug where the notes pop-up remained open when switching between multiple notes.
📸 Preventing Photo Overwrite for Identical File Names
- Previously, photos uploaded with the same name were being overwritten.
- The system now automatically appends a timestamp to prevent file conflicts.
March 03, 8:29am
March 03, 8:29am
These updates are live