ProjectsForce 360 March 9 Release Notes

Informational
March 21, 2:58pm

ProjectsForce 360 March 9 Release Notes

Status: closed
Date: March 08, 7:07am
End: March 21, 2:58pm
Duration: 13 days 6 hours 51 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

March 08, 7:07am

March 08, 7:07am

ProjectsForce Release Notes – March 9, 2025

Enhancements & Fixes for a More Streamlined Experience

📌 CRM: Capture Multiple Addresses for a Client

We’ve enhanced the customer profile experience! Previously, users could only add a single address for a client. Now, you can store multiple addresses and easily designate a Primary Address.

  • A new Customer Address section has been added to the profile.
  • The Primary Address is always displayed at the top and cannot be deleted.
  • Users can search and add new addresses via Google Search or from existing records.
  • When creating a new lead, the Primary Address is automatically populated. Users can also select another saved address.
  • Quotes & Projects converted from a lead will retain the chosen address.
  • This provides greater flexibility in managing multiple job locations for a single client.

🗓️ Customer Portal Calendar & Slot Enhancements

Scheduling jobs online just got simpler and smarter!

Previously, customers had to manually select dates and slots, often facing unavailability. Now, the system only displays available slots, removing the guesswork.

  • Customers select a date, and only available slots will be shown.
  • Unavailable dates are automatically disabled.
  • The system pre-calculates technician availability based on location, scheduling, and efficiency—ensuring the best match.
  • Customers can now quickly schedule their jobs without repeated trial and error.

A screenshot of a computer

AI-generated content may be incorrect.

A screenshot of a computer

AI-generated content may be incorrect.

 

A screenshot of a computer

AI-generated content may be incorrect.


📦 Shipping & Receiving Enhancements

We’ve improved how received packages are displayed for a more structured workflow.

  • Renamed “Inventory” to “Packages Received” – now an independent section for tracking received packages.
  • New “Package Tracking” section – includes an Add Delivery button for easy tracking.
  • UI adjustments ensure each section functions independently for better visibility.

A screenshot of a login box

AI-generated content may be incorrect.


💰 Negative Retail Amount Now Supported

Previously, users could enter negative revenue amounts, but now you can also enter negative retail amounts in:

  • Item Master
  • Project Items
  • Inventory (as Sales Price)

This enhancement allows businesses to easily apply discount line items within a project.


🔔 Push Notifications for Web & Mobile

Stay updated with real-time notifications on Installer Notes, Store Notes, SMS, and Emails!

  • A new Push Notification toggle (blue icon) is now available.
  • Notifications are off by default but can be enabled in Profile Settings (Web, iOS, Android).
  • On Web: Notifications appear in the top-right corner and redirect users to the relevant job.
  • On Mobile: Notifications display in-app and in the notification center, even when the app is closed.
  • Users working with multiple tenants will receive tenant-switching prompts before discarding unsaved changes.

📢 Beta Mode Note: If any issues arise, users can disable push notifications and revert to the previous system.

A screenshot of a computer

AI-generated content may be incorrect.


📢 Pull-Down Notification Enhancements

Unreviewed Store Notes, Installer Notes, SMS, and Emails will now include notifications for:
Cancelled
Closed
Rejected
Completed
Refunded
Reassigned

This ensures better tracking of all job-related updates.


📊 New Filters on Dashboard: User Type & District

  • User Type and District filters, previously available only in the Scheduler and Calendar, are now applicable to the Dashboard for better data control.

🔍 Project Details Tab Enhancements

We’ve improved the Project Details Module with a cleaner UI and better organization:

  • Schedule Info: Added a Technician Table for better job visibility.
  • Additional Fees: Improved layout for easier fee management.
  • Notes: New icons for View, Review, and Delete, with status indicators for reviewed items.

📱 SMS Multi-Line Visibility Enhancement

  • SMS text boxes now expand automatically for better visibility when entering long messages.
  • Scheduled messages will now show a hover preview for easier reading.

A screenshot of a computer

AI-generated content may be incorrect.


🚀 Performance Upgrades

To improve speed and efficiency, commonly used dropdowns and features are now cached to reduce loading times, including:

  • Project Type, Category, Status
  • Issue Category
  • Stores & Workrooms
  • Technician Work Type
  • Company Configuration Details

🐞 Bug Fixes & Improvements

Safari Browser - Add Technician Calendar Fix: Users can now select dates without issues.
Show Loader While Uploading: A loading indicator now appears for photos and documents.
Task Description Length Restriction: Descriptions are now limited to 250 characters to prevent data loss.
Generate Payment Button Fix: Clicking "Generate Payment" no longer refreshes the entire page.
UI Overlapping Fixes: Resolved text and field overlap issues in User Management, Team Reviews, and Crew Management.
Payroll Success Message: Fixed spacing inconsistencies.
Project Description Hover Enhancement: Improved pop-up visibility.
Crew Tab Pagination Fix: Pagination now works correctly for large lists.
HD Survey Duplicate Job Fix: Prevented duplicate job records when multiple technicians are assigned.
Show HD Doc Number: The document number now displays correctly when selecting templates.


That’s all for this release!

Enjoy the new enhancements & fixes to improve workflow, scheduling, and customer experience in ProjectsForce. 🚀💼

Resolved

March 21, 2:58pm

March 21, 2:58pm

These update are live.