ProjectsForce 360 – Temporary Performance Degradation & Emergency Maintenance

Incident
April 03, 12:53pm

ProjectsForce 360 – Temporary Performance Degradation & Emergency Maintenance

Status: closed
Start: April 03, 8:57am
End: April 03, 12:53pm
Duration: 3 hours 56 minutes
Affected Components:
Dynamic Widgets ProjectsForce
Update

April 03, 8:57am

April 03, 8:57am

We want to inform you that ProjectsForce 360 is currently experiencing performance degradation across some components of the platform. Our team is actively addressing the issue and has scheduled an emergency server switch to stabilize performance.

Please note that this action may result in brief access disruptions or complete platform unavailability for a short period. We anticipate the transition will take no longer than 5 minutes.

We will notify you again:

  • When the switch is initiated

  • Once the transition is successfully completed

We sincerely apologize for the inconvenience and appreciate your patience. A full root cause analysis will be conducted, and we are committed to implementing the necessary safeguards to prevent this from happening again.

Thank you for your continued trust in ProjectsForce.

Update

April 03, 9:14am

April 03, 9:14am

Dear Clients,

We have initiated the emergency server switch to address the recent performance degradation affecting some components of ProjectsForce 360.

During this time, you may experience temporary access interruptions or degraded performance. We are working swiftly to complete the transition and minimize downtime.

We will notify you again as soon as the switch is complete and full services are restored.

Thank you for your patience and understanding.

— The ProjectsForce Team

Update

April 03, 9:27am

April 03, 9:27am

Server Transition Complete – System Recovery in Progress

Dear Clients,

The emergency server transition has been successfully completed. We are now in the process of bringing the ProjectsForce 360 platform back to full operational status.

Some components may still be initializing, and you may notice brief delays or limited access during this short recovery period. Our team is closely monitoring the system and working to ensure everything returns to normal as quickly as possible.

We will provide another update in the next few minutes once the platform is fully restored.

Thank you again for your patience and understanding.

— The ProjectsForce Team

Update

April 03, 9:34am

April 03, 9:34am

ProjectsForce 360 Is Now Fully Operational

Dear Clients,

We’re happy to inform you that ProjectsForce 360 is back online and fully operational following the emergency server transition.

Please note: in some cases, you may experience slightly slower load times or delayed responses as the system’s cache continues to refresh in the background. This is expected and will resolve itself shortly.

Our team is actively monitoring performance to ensure everything returns to full speed as quickly as possible.

Thank you again for your patience and understanding. We truly appreciate your continued trust in ProjectsForce.

Warm regards,

The ProjectsForce Team

Update

April 03, 10:57am

April 03, 10:57am

Hey everyone,

I just wanted to take a moment to personally say I apologize for the downtime earlier today.

I know how much you depend on ProjectsForce 360, and I also know that even a short interruption can throw off your day, impact your customers, and cause unnecessary stress. That’s the last thing I ever want for you.

We work hard behind the scenes to make sure things just work. And most days, they do. But today didn’t go that way—and I want you to know we’re taking it seriously. These kinds of issues are rare, but when they happen, we do everything we can to fix them fast, communicate openly, and make sure you’re never in the dark.

You probably saw the updates we sent as the situation unfolded. We tried to keep things clear and transparent the whole time. I believe in owning the tough moments just as much as the wins—and this was one of those moments.

The team is already working through a full root cause analysis, and we’re putting the pieces in place to make sure this doesn’t happen again.

At the end of the day, I care deeply about your success and your experience with our platform. You’re not just users to me—you’re builders, leaders, and business owners I genuinely want to see win. If there’s anything I can do to support you after this, I’m here.

Thanks for sticking with us today. I appreciate you more than you know.

—Chad

Resolved

April 03, 12:53pm

April 03, 12:53pm

This has been closed.