ProjectsForce CX Release Notes – April 6, 2025

Informational
April 20, 9:14am

ProjectsForce CX Release Notes – April 6, 2025

Status: closed
Date: April 04, 6:57pm
End: April 20, 9:14am
Duration: 15 days 14 hours 17 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

April 04, 6:57pm

April 04, 6:57pm

🚀 ProjectsForce CX Release Notes – April 6, 2025

🔍 What’s New in This Release?

  • 💬 All-New Chat Between ProjectsForce Web & Customer Portal
  • 📨 New Unified Communications Tab (SMS + Email + Notes + Chat)
  • 🖥️ Major UI Overhaul in Web and Customer Portals
  • 📄 Dynamic Quote Terms & Conditions with Rich Text Editor
  • 📱 Custom Mobile Visibility for Future & Past Jobs
  • 📁 Related PO Field Now Visible on Documents Tab
  • Auto-Close Carpet & Pad Jobs with Customer Signatures
  • ⚠️ Lead Documentation Warning Pop-Ups
  • 📦 Inventory Receiving Status & Date Enhancements
  • 🧩 Templates Configuration Relocated to Projects Menu
  • 🕒 Realistic Job Durations Based on Line Items
  • 🔍 Set Default Project Audit Reports
  • 🆕 New “Refigure Reason” Field for Lowes Quotes
  • Quick Action Buttons: Send Schedule / Send Complete
  • 🛠️ Bug Fixes in Calendar, Scheduler, and User Management

💬 Real-Time Chat Between ProjectsForce & Your Customers

We're thrilled to introduce a powerful new chat feature that enables direct, real-time messaging between your ProjectsForce Web Portal and your customers’ Customer Portal.

  • Start a conversation right from the Web Portal.
  • Customers can reply instantly from their Customer Portal.
  • New messages trigger a pull-down notification and push notifications (if enabled).
  • Enjoy unlimited daily chat sessions—keeping communication seamless.

🛠️ Available for tenants with Customer Portal enabled.


📨 Introducing the Unified Communications Tab

Say goodbye to scattered conversations—SMS, Emails, Notes, and the brand-new Customer Chat are now combined under one smart, searchable tab: Communications.

  • One place to track all interactions.
  • Easy to manage project communications.
  • Permissions for all communication types are now grouped under Communications.

This unified inbox brings structure and clarity to customer engagement, improving efficiency and accountability for your entire team.


🖥️ UI Enhancements for Better Navigation & Focus

Customer Portal Enhancements:

  • All project sections are now collapsed by default—with the ability to expand only what you need.
  • Pending Signature section is open by default, so your customers don’t miss a beat.

Web Portal Enhancements:

  • Improved mobile responsiveness for:
    • Header bar
    • Sidebar
    • Dashboard
    • Admin
    • Calendar
    • Scheduler
    • CRM Client Profile

📄 CRM: Dynamic Quote Terms & Conditions

You can now create custom, rich-text Terms & Conditions in quotes with the ability to:

  • Format with bullet points, styles, links, and more.
  • Save templates for easy reuse.
  • Select from dropdowns instead of rewriting each time.

This upgrade delivers both professionalism and efficiency.


📱 Mobile Visibility Control for Past & Future Jobs

Admins can now control how far back or forward technicians can view jobs using permissions like:

  • 3d for the past 3 days
  • 24h for the next 24 hours

This ensures your team sees only what’s relevant, improving focus and compliance.


📁 Documents Tab: See Related POs

A new “Related PO” field is now available on the Documents tab at the project level:

  • Shows PO numbers for any linked child jobs.
  • Available for tenants using Project Linkage.

Auto-Close Jobs with Customer Signatures

For Carpet and linked Pad jobs:

  • When a signed customer approval is present, the system will automatically close both jobs.
  • Signature will be attached to both job records.

Let us know if you'd like this feature enabled for other job types!


⚠️ Lead Job Documentation Alerts

While scheduling or changing work types, ProjectsForce will now:

  • Show a pop-up warning if lead documents or tests are missing.
  • Display a checklist of pending docs (for Home Depot jobs).
  • Trigger the same alert when changing status to “Contract Reviewed.”

📦 Inventory Receiving Enhancement

Upon receiving products:

  • Line items now turn green.
  • Status changes to “Received.”
  • Today’s date is recorded.

The system will create the “Received” status if not already set up.


🧩 Templates Configuration Moved for Easier Access

The ability to create email and quote templates is now located under the Projects menu instead of Admin. This:

  • Makes templates more accessible.
  • Can be permissioned by role.
  • Is disabled by default to prevent unwanted access.

🕒 Estimate Job Duration Using Line Items

We now calculate realistic job durations based on the labor items added:

  • Each labor item can have a defined service time per unit.
  • The system will total the expected duration and reflect it in:
    • Project Cost Summary
    • Schedule Info (Job Duration in Minutes)

You can also:

  • Click a button to recalculate service time if items change.
  • Get prompted when manually editing duration, ensuring consistency.

🔍 Audit Logs: Set Default Report

Admins can now designate a default audit report for the Projects Audit Logs tab, so users no longer need to switch reports on every job.


🆕 New “Refigure Reason” Field for Lowes Quotes

For quotes from Lowes:

  • A new Refigure Reason dropdown is available under Project Details.
  • Default options included—customizable by request.

Quick Action Buttons: Send Schedule / Send Complete

Two new buttons added (must be enabled by Admin):

  • Send Schedule triggers scheduling when criteria are met.
  • Send Complete triggers completion when the job is ready.

Supported for:

  • Home Depot and Lowes
  • Based on current source statuses

🛠️ Bug Fixes

  • Calendar/Scheduler Scrolling: Fixed issues when scrolling quickly through technician lists.
  • User Management Navigation: Resolved missing Next/Previous buttons after filtering users.

Need assistance or want to enable any new features? Contact your Account Manager or email support@projectsforce.com.

We’re always improving ProjectsForce to make your workflow smoother, smarter, and more connected—thank you for being part of it!

Update

April 05, 11:18am

April 05, 11:18am

📣 REMINDER: Major UI Update Launching Tomorrow – New Communications Tab

Hi team,

🚨 Just a quick reminder that a significant UI update is going live tomorrow as part of our latest ProjectsForce release:

🌟 Introducing the all-new Communications Tab.

We’ve consolidated SMS, Emails, Notes, and the brand-new Chat feature into a single, unified tab called Communications.

Here’s what you can expect:

✅ A streamlined, centralized thread for all project-related communication
✅ Cleaner, simplified permissions—all communication types now live under one hierarchy
✅ A messaging experience inspired by WhatsApp, Messenger, and Slack—customized for field service workflows

🔔 Important note:

  • The tab consolidation will apply to all tenants.

  • The new real-time chat feature will only be available to tenants using the Customer Portal.

This is one of our most exciting and forward-thinking updates yet—designed to save you time, reduce confusion, and enhance your customer communication experience.

If you have questions or want support reviewing your team's permissions ahead of the release, feel free to reach out!

Thanks,

Chad

ProjectsForce – Built for What’s Next

Update

April 07, 7:28am

April 07, 7:28am

📣 Reminder: New Communications UI Goes Live Today

Hi team,

Starting today, users will see the updated Communications UI across both the Communications Center and the brand-new Communications tab in ProjectsForce.


This update brings all project-related communication—SMS, Email, Notes, and Chat—into one unified, organized space designed to streamline collaboration and improve visibility.


🔔 Important Action Required (For Tenants Using the Customer Portal)

If you're currently using the Customer Portal and want your users to access the new Customer Chat feature, an Admin must update role permissions today.

To enable access:

  1. Go to the Admin section in the left sidebar menu

  2. Click User Management

  3. Select Manage Roles

  4. For each role that needs access to the new chat:

    • Scroll to the Communications section in the permissions list

    • Enable the checkbox for “Customer Chat”

🚫 If this permission is not granted, users will not see the Customer Chat icon or be able to access chats in the Communications tab.



If you need help updating roles or have questions about this update, feel free to reach out to the support team or your ProjectsForce Account Manager.

Thanks for staying up to date!

– Chad 

ProjectsForce – Built for What’s Next

Resolved

April 20, 9:14am

April 20, 9:14am

These updates are live.