ProjectsForce 360 • April 20, 2025 Release Notes

Informational
May 04, 10:51am

ProjectsForce 360 • April 20, 2025 Release Notes

Status: closed
Date: April 20, 9:14am
End: May 04, 10:51am
Duration: 14 days 1 hour 37 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

April 20, 9:14am

April 20, 9:14am

ProjectsForce 360 • April 20, 2025 Release Notes

We’re excited to announce a host of new features and enhancements designed to give you more flexibility, improve your mobile experience, and streamline your workflows. Read on to learn what’s new—and how to get started.


🚀 Project Details: Fully Customizable Layouts

What’s changing?

  • Custom Layout under Visual Enhancements lets Tenant Admins design their own Project Details page.

  • Create multiple cards to group fields, name them, and position them above or below tabs.

  • Rearrange tabs, hide unwanted fields, resize cards, and mark cards read‑only for specific roles.

  • Assign one or more layouts to user roles via the gear icon in User Management.

Getting started:

  1. Go to Admin > Visual Enhancements > Custom Layout.

  2. Build and save your layouts.

  3. In User Management, click the gear icon next to a role and select the layout(s) that role should see.


📱 Mobile App (Android): Technical Upgrade & Dashboard Drag‑and‑Drop

Highlights:

  • New Android version with core technical upgrades for faster, more reliable performance.

  • Dashboard cards can now be rearranged via drag‑and‑drop—just like on iOS!

Roll‑out plan:

  • Optional release on Saturday morning for users with auto‑update enabled.

  • Mandatory update by Monday morning for all users.

  • You’ll receive an in‑app prompt—please update your app via the Google Play Store.

  • If you see a blank screen or cannot log in, uninstall and reinstall the latest version; you’ll be prompted to sign in again.


🔄 Rotation Percentage by Store

Enhancement:

  • Define technicians’ rotation percentages not only by work type and category, but now per store.

  • When jobs are pulled or created, the system identifies eligible technicians by type, category, and store, then assigns work proportionally.


🤝 Auto Technician Assignment Improvements

  1. Job Assignment Coverage

    • New option under Auto Assignment selects technicians based on unique “coverage” tags.

    • Admins must ensure each coverage combination maps to only one user—any duplicates will trigger an alert until resolved.

  2. Tech Based on Related PO

    • Check this box to assign installation jobs to the same technician who completed the measurement (and vice versa).

    • Falls back to your selected assignment method if no related PO is found.


🗺️ Map View: Independent Menu & Unified Filters

  • Maps is now its own permissioned submenu under Projects—grant access via role permissions.

  • The Map menu and the scheduler’s Maps tab now share the same Global Filters, so you set them once and they apply everywhere.


✅ Project Task Indicator & Close‑Task Permission

  • New Close Tasks permission lets users mark any task complete, even if they didn’t create or own it.

  • Projects with open tasks display an “Open Tasks” indicator in the top bar—once all tasks are closed, the indicator disappears.


🔗 Linking Blinds Jobs as Parent/Child POs

  • For jobs from the Blinds.com portal and Home Depot Service Center, the system now automatically links matching projects as parent and child POs (matched by com_order_number and project_number).

  • To enable for your tenant, please contact our Support team.


➡️ Automatic Lead Creation for F&I Pro Measurement POs

  • All Home Depot Service Center (Pro Sales PO) measure jobs now auto‑generate a Lead under the customer’s Leads tab—just like standard Home Depot leads.

  • To enable for your tenant, please contact our Support team.


⏱️ Project Time Management: New Milestone Fields

Under the Time Management tab in Project Details, you’ll now see three static and calculated fields to track scheduling performance:

  1. First RTS Date – the first date your order reached Ready to Schedule (never changes).

  2. Duration WFP → RTS – days between Waiting for Product and first RTS (static).

  3. Duration RTS → Scheduled – days from first RTS to Scheduled, recalculated if you change the scheduled date.

These fields are also available in your widgets for easy monitoring.

Resolved

May 04, 10:51am

May 04, 10:51am

these updates are live.