ProjectsForce 360 May 4, 2025 Release Notes

Informational
May 16, 10:34am

ProjectsForce 360 May 4, 2025 Release Notes

Status: closed
Date: May 04, 10:51am
End: May 16, 10:34am
Duration: 11 days 23 hours 43 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

May 04, 10:51am

May 04, 10:51am

NEW: Auto Scheduling Now Available in the Web Portal

We’ve expanded our popular Online Customer Scheduling feature—originally available in the customer portal—to the ProjectsForce 360 web interface. Now, your team can instantly view available dates and time slots when scheduling projects, using the same intelligent logic that considers technician availability, coverage areas, work schedules, time off, job caps, and more.

How it works:

  • Contact support to enable this feature.

  • Admins will gain access to a new “Schedule Now” permission.

  • A “Schedule Now” button will appear on each project.

  • One click opens a list of eligible dates and time slots.

  • Select a slot to auto-schedule the job—no manual checking or guesswork.

This streamlines scheduling during customer interactions, saving time and boosting efficiency.


📦 Inventory Enhancements

We’ve made managing inventory faster and more flexible:

Item Master Updates:

  • Category Field: Dynamically create or assign item categories.

  • Stock Toggle: Identify stocked vs. non-stocked items in one click.

Warehouse Stock Updates:

  • Enhanced item tracking with added fields:

    • PO Number

    • Customer Name

    • Stock Indicator

    • Category

    • Adjustment Type

    • Adjustment Date

New Functionalities:

  • Advanced filters to search and manage inventory faster.

  • Download Button: Export data to Excel for offline ops.

  • Pagination extended to 500 records for high-volume visibility.


📄 Set Default Document Status (Web & Mobile)

Avoid repetitive dropdown selections. Admins can now configure a Default Document Status per template (e.g., Internal, External) directly in the Document Center. Once set:

  • That status auto-populates each time a user adds the document to a project.

  • Users can still manually change it if needed.


📝 Set Default Note Type (Web & Mobile)

Admins can now define a default note type for projects via Company Configuration → Project Management. Once set:

  • All users will see this note type pre-selected by default when adding notes.

  • Reduces clicks and improves consistency across the platform.


📊 New Fields Available for Reporting Widgets

We’ve exposed new fields in table-based widgets to help with financial and job tracking:

  • Mark All as Finance Reviewed

  • Mark All as Paid

  • Technician Arrival Start Time

  • Technician Arrival End Time

Use these to enhance dashboards and operational visibility.


🧹 Legacy Module Cleanup

We’re retiring outdated versions of several features, as customers have fully adopted newer, stable replacements. The following modules will be removed:

  • Activities Tab

  • Issues Tab

  • Old Project Items

  • Old Related POs

  • Site Inspection

  • Old Time Management

  • Legacy Scheduler

  • Pull-Down Notifications (push notifications will remain)

If you experience any issues, contact support.


📱 Mobile Updates

New: In-Progress Job Status

  • Mobile users can now mark jobs as In-Progress, just like on the web.

  • “Not able to complete” has been renamed to Not Able To Complete for clarity.

Digital Badge In-App Display

  • Digital ID Badges now open directly within the mobile app—no browser redirect required.


🛠️ Bug Fixes

Customer Portal – Online Scheduling:

  • Fixed an issue where technicians with block time or partial time off were being skipped entirely. Now, they’ll be considered for scheduling outside their unavailable hours.


If you have questions or need support enabling any of these features, reach out to your ProjectsForce 360 Account Manager or contact our Support Team.

Resolved

May 16, 10:34am

May 16, 10:34am

These updates are live.