ProjectsForce 360 June 1 Release Notes

Informational
June 06, 9:29am

ProjectsForce 360 June 1 Release Notes

Status: closed
Date: May 30, 11:11am
End: June 06, 9:29am
Duration: 6 days 22 hours 18 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

May 30, 11:11am

May 30, 11:11am

ProjectsForce 360 June 1, 2025 Release Notes:


New Feature : Alias For Custom Layout Fields

As part of further enhancing the new custom layout feature, system would now allow admins to rename the fields while adding to the forms as per their wish, which would be visible for that tenant through out the application on all new layouts only. This feature would let admin select the custom fields with custom names to fully control the visibility for their users.

New Feature : Mobile - Need Support

Similar to the Web version, For Lowes jobs - the Need Support functionality is not being added on the mobile devices as well, which would help the technicians working on Lowes jobs to raise the support request for retailer directly from their mobile devices. This would be controlled via the permissions similar to the web version.

 

New Feature : Mobile - Checklist

Similar to the web version, our fully dynamic checklist module would be now released for the Mobile devices as well. This would give an ability to an admin to setup any kind of form with any type of questions to be answered or information to be captured against defined job categories from the technicians on the mobile devices. This would use the same permissions configured for web version.

 

 

New Feature : Purchase Orders Linked To Project

ProjectsForce 360* is releasing a new feature to manage the Vendors and send them the dynamically created purchase orders Via the Email to place the order of the items against a job and track the same.

This feature can be enabled by connecting with the support team and all these options would only be seen after that to the users having the required permissions for each menu or newly added button as defined below:

  • Project → Vendor Management : A new feature has been added to create and manage the Vendors, where in all required details of the vendors like name, company details, billing address, carrier preference etc. can be added along with the mode of communication.

  • Generate Checklist For Vendors: A checklist with module as Vendor, needs to be used to setup the dynamic form or a template to be considered for specific vendors. While creating a checklist, admin can use the questions with a table type or multiple questions within a card. For both type of questions, user can link the fields with pre-defined options like Item #, Description, Cost each etc to populate the data on its own against the project items.

    •  

  • Link Items to Vendors: In the Item master, the admin can link the items specific to the vendors by selecting the already created vendors in above step and configuring against all required vendors.

  • Generate POs: User with the permissions, would see a new button under the Project Items tab as Generate POs, on click of that based on the vendors linked to the available items under the job, user would see the name of vendors and on clicking any of them, system would find the checklist for that vendor, pre-populate details of all linked items, contact details, other fields automatically on the order form. User just have to review the same and could send the email directly to the vendor, if the communication channel is set as Email for that vendor from the ProjectsForce or can download the same to send separately.

    •  

  • Track the Purchase Orders: Users can see the list of all the placed orders under the Projects in a new tab as Purchase Order with the initial status as Order Generated / Order Placed (If Email is sent) and can then manually change the status based on the order status.

This feature would help users to place orders and directly communicate with the vendors efficiently with just a button click.

New Feature : General Purchase Orders

Similar to the Project based Purchase orders, users can also place the generic purchase orders as defined below:

After the required permissions are given by support team and present on the role, user would see a new menu as Project → General Purchase Orders where in user can view the old orders or create the new order.

After selecting the vendor from the dropdown and clicking on Create button, user would see the checklist configured for that specific vendor with all the basic details being fetched and user can add the Items, which are only linked to that vendor in item master and its quantity to order, along with all other required information for the Purchase order.

Once the purchase order is submitted, user can preview the same later, change the status or send the email directly to the vendor as an attachment in an email, if the communication is set as Email for the vendor.

CRM - Ability to view or edit Lead records from Widget

As an enhancement in this release, going forward the widget created from the Leads table would now also has the ability to view or edit the corresponding lead, by clicking the eye or pencil icon resp, similar to the experience which user gets while creating a widget from Projects table.

CRM - Client Module & Site Module Enhancement

ProjectsForce would be making a change in the Client module to allow tenants to categorize their customers and capture more details information for them as below:

Type of Customer: Now tenant can define the type of their clients as Residential or Commercial, default value would Residential for all existing clients and Company Information is now would be visible only in case of commercials clients

Multiple Contact Details: Now user can add multiple contract details for a single client into their profile for better connectivity and visibility.

Customer Address → Sites

With this release, now the Customer address would be renamed as Sites under the client profile, where in now users can manage multiple information of that client against their different sites like

Site contact details, Site specific notes, documents, Photos, Installation Address, send emails directly.

Also when a quote is created directly from a Site, it would consider its address as Installation address by default while creating quote, projects, invoices etc.

CRM - Modifications on Quotes

System would make a change in Quotes to now show the billing and shipping address both on the top sections based on the default address or the site being selected to generate the quote from.

Description of quote would also be added now just below the address in both quote and invoice preview. Also if the payment info is not present then system would not show the payment related labels.

CRM - Edit Labor and Product description

System would make a change where in now user while creating a quote and selecting an item can edit the description of the line item on top of the description present in the Item master, which would be specific to this quote version and would be carry forwarded to the generated Project or Invoice. This allows customers to share the modified and details description to their specific customers as required.

Also the dropdown for the Items and Descriptions has been expanded for better visibility

UI Enhancements

System would be enhancing the UI for below modules for better performance and maintaining symmetry with the other modules.

  • Labor Profile Page

  • Project Details → Permitting

  • Dashboard listing page

  • Payment Request

Mobile - Auto Scheduling UI Enhancements

System would be enhancing the UI on Mobile, similar to web version for online scheduling feature, where the technician would accept or decline the request raised by the customers.

Bug Fixes

UI Issue on Mobile - Video upload with big names: System would fix a bug where in the UI was breaking on Mobile in case of a bigger video names


Issues on Quotes tab: System would fix below bugs on the CRM Quotes module:

  • Photos and docs added on quote were not getting transferred to project when converting to project from quote.

  • Terms and condition does not get populated on the quote and invoice preview.

 

Pop up Map Pin when scheduler is opened from Project: When a Map on Scheduler would open from a Project, system would now show that Project Pin popped up by default on Map without any filters being considered.


Admin configuration Technician View & Map Pins in Color Code disabled automatically:

System would fix a bug where in the Technician View and Map Pins flag was getting disable by making any other change on Company configuration

Next & Previous Buttons:

System would fix the bug where Next and Preview buttons were getting disappeared in case of modifying anything on the Project page

Resolved

June 06, 9:29am

June 06, 9:29am

These updates are live.