Unplanned Release: Dashboard Performance Boost (June 6, 2025)

Informational
June 13, 1:21pm

Unplanned Release: Dashboard Performance Boost (June 6, 2025)

Status: closed
Date: June 06, 9:29am
End: June 13, 1:21pm
Duration: 7 days 3 hours 52 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

June 06, 9:29am

June 06, 9:29am

Unplanned Release: Dashboard Performance Boost (June 6, 2025)


Why the sudden push?

We found a quick win to make dashboards snappier, so we shipped it instead of waiting for the next cycle.

What’s changing?

AreaWhat you’ll see
Dashboards & WidgetsBehind-the-scenes performance refactor. First load will be a bit slower while we rebuild caches; every load after that should feel noticeably faster.
New Button“Disable Beta” (temporary, top-right). Dashboard now opens in Beta mode by default. Hit the button any time to fall back to the previous version.

What to expect

  1. First visit after the update: brief delay—let the cache build.

  2. Next visits: faster loads and smoother widget rendering.

  3. Issues? Click Disable Beta and you’re back on the old dashboard in seconds—no data lost.

Need help or want to weigh in?

Spot a hiccup or don’t feel the speed bump? Tell us. Reply to this email or drop a note through in-app chat with details (browser, steps, screenshot if possible).

Thanks for rolling with the quick release. Your feedback keeps us iterating fast.

Resolved

June 13, 1:21pm

June 13, 1:21pm

These updates are live.