ProjectsForce 360 June 29, 2025 Release Notes

Informational
July 27, 7:09am

ProjectsForce 360 June 29, 2025 Release Notes

Status: closed
Date: June 30, 7:13am
End: July 27, 7:09am
Duration: 26 days 23 hours 56 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

June 30, 7:13am

June 30, 7:13am

ProjectsForce 360 Release Notes

Release Date: June 29, 2025


🔧 Payroll, Chargebacks & Retainage

  • Chargeback Updates

    • You can now edit chargeback payout entries up until payment is made—even if the chargeback date is in the past.

    • A new Admin Fee field has been added to the Chargeback Summary, alongside Material and Labor Chargebacks.

  • Payroll Enhancements

    • Chargeback reasons now appear in exported payroll reports for improved clarity.

    • Workroom filter in payroll reports is now a multi-select dropdown.

  • Retainage

    • Like chargebacks, you can now edit payout entries on retainage until they’re paid.


🛠️ Scheduler Enhancements

  • New Quick Action: Customer Issues

    • A new “Customer Issues” button is now available (permission-based).

    • Clicking this updates the internal status and opens an issue form. Descriptions are added as internal job notes.

  • RTS Table Update

    • When accessing the scheduler from any job, that job will now always appear in the RTS table—regardless of status filters.

    • You’ll also see eligible techs on the calendar below for assignment.

  • Clear RTS Date Automation

    • New feature clears RTS dates when setting statuses to:

      • Completed

      • Needs Review

      • Dispatched

      • In Progress

      • Waiting for Product

    • This is configurable per tenant.

  • Compact Scheduler View

    • Toggle a new “Compact View” on the calendar to shrink job cards for better visibility of tech schedules.

    • View preference is saved during your browser session.


📱 Mobile & Web Enhancements

  • Busted Job Updates

    • New toggle allows users to clear the confirmation status when marking a job as “Busted.”

  • ETA at Project Level (Home Depot Jobs)

    • The latest delivery date from line items now populates the ETA field under Schedule Info.

  • Restrict Completion if Contract Pending

    • A new tenant permission hides the Complete button if the job is marked as “Contract Pending” to prevent premature completion.

  • Offline Sync Improvements

    • Badges now show sync progress after logging in or reconnecting.

    • Failed document downloads now display an icon indicating retry is needed.

  • Dropdown Scrolling for Mobile

    • Long dropdowns (Statuses, Types, etc.) now scroll instead of covering the whole screen.


📝 Notes Enhancements

  • Default Note Type Now Applies to Status Change

    • Default note type (as set by the admin) now applies when changing status from “Waiting for Product” to “Ready to Schedule.”


🧾 CRM & Quotes

  • Default Sales Tax at Company Level

    • Admins can now set a default sales tax rate at the company level (up to 99.999%).

    • Tax is applied only to taxable line items and carries through to Quotes, Projects, and Invoices.

  • Taxable / Non-Taxable Quotes

    • New toggle lets users classify a quote as taxable or non-taxable.

    • The system auto-applies or removes tax based on this setting.

  • Display Tax Percent on Quotes

    • Quotes now display both tax amount and tax percent for consistency.


🗂️ Permissions & Controls

  • Control Add Project Category

    • Admins can now restrict which roles can add new project categories on-the-fly.

  • Tenant-Specific Project Types

    • Project Types are now tenant-specific. Reach out to Support if you want to add or remove options unique to your business.


🏗️ Project Permitting → Regulatory Overhaul (IMPORTANT)

  • The Project Permitting tab has been renamed to Regulatory.

  • Fields have been renamed for broader use across regulatory needs.

  • A new Type dropdown and dynamic Status field have been added.

  • The interface has been upgraded for clarity and customization.


📸 Media Improvements

  • Download Icon on Photo & Video Cards

    • Quick download option now appears directly on photo/video cards.


☎️ Left Message Enhancements

  • Added Left Message 4 as a new quick action status.

  • Once a job is reset to “Ready to Schedule,” message count resets to allow reattempts.


🔐 SMS OTP Support

  • Users now receive One-Time Passcodes via SMS in addition to email for easier login verification.


🐞 Bug Fixes

  • ✅ Payroll: Reviewed/Paid flags now sync correctly.

  • ✅ Mobile: Badge ID for crew members now visible.

  • ✅ Auto Tech Assignment now excludes inactive installers.

  • ✅ Mobile: SMS history timestamps now respect local time zone.

  • ✅ Notes Sync: Original created-by dates now carry to child jobs.

  • ✅ Arrival End Time now auto-populates after setting Arrival Start Time.

  • ✅ CRM: Tax now calculated on discounted amount, not full value.


For any issues or to enable new permissions, please contact our support team.


ProjectsForce 360 – Built for how you work.

Resolved

July 27, 7:09am

July 27, 7:09am

These updates are live.