ProjectsForce 360 August 2025, Release Notes

Informational
September 26, 3:12pm

ProjectsForce 360 August 2025, Release Notes

Status: closed
Date: August 29, 10:29am
End: September 26, 3:12pm
Duration: 28 days 4 hours 43 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

August 29, 10:29am

August 29, 10:29am

ProjectsForce 360 August 2025, Release Notes

Important - New Feature & Documents Signature Enhancements 

Purpose :

ProjectsForce 360* would be releasing an update on the Document Center module to the latest stable version to ensure compatibility, security, performance, and access to new features. 
In addition, multiple enhancements have been made to improve document signing workflows, integrity, audibility, and user experience across the platform. 

  

  • Enhanced Signature Workflow & New Feature

    • Introduced pen color indicators to visually reflect signing state: 

      • Grey → No signatures. 

      • Orange → Partially signed. 

      • Green → Fully signed. 

    • Pen icon includes a tooltip showing the latest or last signed date, with signature details available on hover. 

  • A new feature as Sign anywhere can be set from document center for templates and also for new upload of project documents. The permission for setting sign anywhere can be set for documents which are marked as Editable and Signature Required.



    • Added new annotation option under the custom dates to stamp the latest signature date or choose a custom signature date

    • Signature Log & Audit Trail 

    • Implemented a comprehensive signature log history that captures: 

      • Who signed and when

      • Type of signature (Sign anywhere or Form-Field Signature). 

      • Total signatures required, signatures added, and pending counts. 

    • Log is accessible in both Document Center and Project Document section

    • Signature logs are also captured across Mobile app, Customer Portal, and Tiny URL workflows






      • Imp : Validation & Send-to-Source Enhancements 

        • Added validation on Save and Bulk Update actions to ensure unsigned documents cannot be sent to source when signature is required. 

        • Unsigned document names are listed during bulk validation for clarity. 

        • Added an info icon next to Project Documents to highlight send-to-source rules for unsigned documents. 

        • Added warning pop-ups when attempting to send unsigned documents where signatures are required. 

      • Editing & Annotation Enhancements 

        • Introduced signature annotation support in edit mode

        • Enhanced differentiation of signature types: 

          • Sign Anywhere 

          • Form-Field Signature

        • Tooltip now shows counts of both signature types and required totals. 

      Special Note on the change for Signature Icon Behaviour for Mobile

      The signature icon looks the same on both Android and iOS, but the actions differ slightly: 

      On iOS:

      • Tap the Signature icon.

      • The signature pad will appear.

      • After signing, the signature will be placed in the center of the document.

      • You can drag and position the signature wherever you like. 

      On Android:

      • Tap the Signature icon.

      • It will activate annotation mode.

      • Tap on the spot in the document where you want to place the signature.

      • The signature pad will open for you to sign.

      • After signing, to move the signature, first deselect the signature icon, then select the signature and drag it to the desired location.

      New Feature - SMS on Mobile Devices

      Similar to the web, now mobile users would also be able to communicate to the end users directly via the SMS functionality, along with this they can clearly see all the conversation being done between the customer and their company users along with date and time and the user details.

      Until the message gets delivered, user can also modify the message as required. This feature is available only in the Online mode.

      Existing permissions would be used under the Project Details → Communications → SMS to control the feature visibility on web and mobile both.

      Important Change in User Experience For SMS History on Web

      To enhance the user experience, the SMS history under the Project Details → Communications → SMS would be changed to give user a new experience to see all the messages being sent by the user properly aligned on the right side of the window and all other communications being done by other users or end customers on the left side and sorted by the timeframe. This is now kept in Sync with the new feature rolled out on mobile.

      New Feature : Scheduler - Horizontal View

      For the better visibility and operations, system is releasing a new tab under the Scheduler and Calendar as Horizontal View, this would show the technicians names horizontally and giving more visibility on the wider screen to view the assignments and easily assign or reassign the jobs across the technicians.

      Apply Custom Discount or Tax On Quote Labor or Product Items

      Recently ProjectsForce 360* released the feature to define the Sales Tax to be applied on Quotes, configured at the company level for the taxable lines, along with an option to override the company level defined tax against required line items, or mark the quote itself as Non Taxable.

      As an enhancement in this release, user would now also see a toggle button (by default Off) under the Quotes to manually define the custom discount (in percent or amount) and tax to be applied exclusively for Labor or Product items





      Project Items - Finance Reviewed Enhancements

      ProjectsForce 360* is making an enhancements on the Finance Reviewed flag present on the Project Items to keep the consistency from Project Items and Payroll reports along with below changes to manage the payroll efficiently:

      1. If any change is made on Line item or technician, Finance Reviewed will be uncheck with the warning message ,if it is already checked.

      2. If all the child jobs are finance reviewed  (totally 100% allocated), then it should automatically reflect and mark parent job as "Finance Reviewed" in project item tab.

      3. For all the child jobs (totally not 100% allocated) , if marked as Finance Reviewed, will not mark the parent job as Finance Reviewed automatically and a warning message will appear if user try to click on checkbox for the child jobs as "This line item is not assigned for 100% allocation; you are marking it as Finance Reviewed, Do you want to make it Finance Reviewed for parent item also?", user can choose any of out of below 2 options .

        1. If user clicks on "Ok" button , then parent will also be marked as Finance Reviewed.

        2. If user click on "Cancel" icon, the parent will remain as is and the child job will be marked as Finance Reviewed.

      4. If any technician is Finance Reviewed for the assigned job , then 

        1. While deleting it from schedule Info tab, then finance reviewed would get reset based on item level after the confirmation on the warning message.

          1. Single technician , then "Finance Reviewed" will be unchecked from parent line item

          2. Multiple Technician , then parent will remain as is in Finance Reviewed, only if all other technicians are finance reviewed.

      5. User can uncheck parent or child level Finance reviewed (Until it is being marked as PAID) after providing the confirmation on the pop up: "Please confirm if you would like to uncheck the Finance Reviewed?"

      6. If we uncheck finance review from project item then the same will reflect on Payroll.

      7. If by mistake someone clicked finance reviewed, the same can be reverted back, until the line is paid

      Project Items - Paid Enhancements

      ProjectsForce 360* is making an enhancements on the Paid flag present on the Project Items to keep the consistency from Project Items and Payroll reports along with below changes to manage the payroll efficiently:

      1. If all the child jobs are paid (totally 100% allocated), then it should automatically reflect on parent job as PAID in project item tab and should not be editable then.

      2. For all the child jobs (totally not 100% allocated) , if marked as paid, will not mark the parent job as paid automatically and a warning message will appear if user try to click on PAID for the child jobs as "This line item is not assigned for 100% allocation; you are marking it as PAID, Do you want to make it PAID for parent item also?", user can choose any of out of below 2 options .

        1. If user clicks on "Ok" button , then parent will be marked as PAID

        2. If user click on "Cancel" icon, the parent will not be marked as PAID but the child job will be marked as PAID.

      3. If any technician is PAID for the assigned job , then 

        1. It should not get deleted from schedule Info tab 

          1. Delete button in read only mode in schedule info for the paid technician , and a tooltip with info of why it cannot be deleted.

        2. It should not be deleted from MAP view.

      4. Log time would be shown on Payroll also, as it is currently visible on line items once the job is Paid.

      Push Notifications Visibility Enhancements

      Existing workflow:

      1. Push notifications and pull down notification works on basis of the user level coverage permissions and role based permission about Project → Project Details → Communications →

        1. Email

        2. SMS

        3. Store Notes

        4. Installer Notes

        5. Customer Chats

      2. The other existing permission is used to identify if the user has installer permissions. The installer check is done by using View Installers Permissiosand any user without this is not considered as a non-installer user.

      3. Notification is added to non-installer user based on point 1 basis permission while Technician users are assigned notification only if they are assigned to the specific project.

       

      New Change:

      1. System would add a new permission for pull down menu as User Assigned.

      2. Remove existing dependency on installer permission and use the above-mentioned permission.

      3. For roles which currently have installer special permissions, check if they have User Assigned pull down permission.

        1. If the user doesn’t have pull down menu User Assigned permission, we treat the user as non technician user and show all the notification based on coverage preference and other role permissions.

        2. If the user does have pull down menu User Assigned permission, we treat the user as technician user and only show notification for the projects they are assigned to.

       

      Mobile - Important Change For Child Jobs

      To make the seamless experience for the technicians using the mobile devices, system would rollout a change on mobile devices where in going forward the technicians would not see the child jobs along with that would see the line items of the child jobs under the parent jobs itself as a linked line items for Labor and Product both, similar to web version.

      This enhancement would avoid any accidental changes or data being captured on child which gets override while syncing the child jobs from parent.

      Mobile - Timezone Changes

      Recently a change was done to manage the jobs scheduled date as is for all users irrespective of their local time zone, the same is being now done for all the mobile modules including Scheduling, Time Off etc. This would ensure that the users of the company would see the time based on the time zone defined at the company level and would not change based on their local time zones.

      Bug Fix : Customer Portal Sign Up and Sign In Page Redirection

      System would be fixing the redirection bug on customer portal, where in now end users have to first enter their email Id and if they are signing for the first time would get redirected to the Sign Up page to create their account, Once the account is created and validated going forward for all future attempts they would directly get redirected to Sign In page after entering the email Id.

Resolved

September 26, 3:12pm

September 26, 3:12pm

These updates are live.