ProjectsForce 360 October Release Notes

Informational
October 31, 4:13pm

ProjectsForce 360 October Release Notes

Status: closed
Date: September 26, 3:16pm
End: October 31, 4:13pm
Duration: 35 days 57 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

September 26, 3:16pm

September 26, 3:16pm

ProjectsForce 360

October Monthly Release

We’re excited to share the latest updates designed to improve efficiency, visibility, and usability across ProjectsForce 360.


Paid & Unpaid Labor Cost Summary

  • New fields Paid Labor and Unpaid Labor are now available in the Project Items cost summary.

  • These fields display the total dollar amounts of line items marked as paid vs. unpaid.

  • Widgets under the Project Table now include Paid Labor $ and Unpaid Labor $ for quick visibility.


Payroll Enhancements

  • A new Final Export button allows office staff to complete validations and mark all line items as exported, preventing duplicates in future reports.

  • Exported payroll reports now include:

    • Exported (Yes/No)

    • Exported Date

    • Exported By

  • Widgets under Project Tables also display export attributes for added clarity.

  • Two new filters make it easy to manage exported vs. pending items.


User-Based Auditing (Add-On Feature)

  • Tenant admins can now enable detailed auditing to track login/logout times and user actions (e.g., scheduling, job updates, customer contacts).

  • A new User Activity menu under Admin provides:

    • Filters by date, action, and user

    • Hyperlinks to detailed project updates

    • Export options to Excel


CRM & Client Management Enhancements

  • Auto Leads & Projects: When creating a client, a pop-up now prompts users to create leads and projects immediately—no extra steps required.

  • Client Creation from Project Page: If text entered in the client or category fields doesn’t exist, a new icon allows users to create and link the record instantly.

  • Quote Workflow: From measurement projects, quotes can be created manually or from templates. Approved quotes auto-generate jobs.


Project Copy & Item Visibility

  • Copy Project Items: Copying a project now gives the option to include Project Items along with basic details (no technician assignments).

  • New Project Items View:

    • Key fields show upfront; secondary fields expand only when needed.

    • Tenants can configure this as the default view, with users able to override for their session.


Permissions & Controls

  • New permissions for pull-down icons (Installer Notes, Store Notes, SMS, Email) provide finer control over what users see in the top bar.

  • A new User Assigned permission has been added for global search.

    • Users with this role can only search for projects assigned to them.

    • Admins can disable this setting for roles that need broader access.


Scheduler & Map Enhancements

  • A new Scheduler Synced Map toggle ensures map data always matches the calendar view.

  • Map and Split View buttons have been simplified, with an info icon added for clarity.


Pull-Down Notifications Updates

  • Notifications now show only the last five days for better performance.

  • Installer and Store Notes are merged.

  • CRM communications (SMS, Email, Client, Lead, Quote, Invoice, Payment) are now included.

  • Role-based controls determine who sees which notifications.


Finance & Payment Controls

  • Line items cannot be edited after finance review.

  • Paid jobs can no longer be moved on the calendar.

  • Pinned Notes: Schedule Notes are renamed to Pinned Notes for clarity.

  • Payment requests now allow check and requested amounts less than $1 (but greater than $0).


Service Time Entry

  • All service times must now be entered in MM:SS format for consistency.


Mobile UX & Performance

  • Documents, photos, and videos now appear in separate tabs instead of a single scrolling list.

  • Closing a document no longer redirects users to the details page, making navigation faster.


Permissions Cleanup

To simplify role management, unused permissions have been removed, including:

  • Dashboard Filter

  • Site Inspection

  • Store Notes

  • Template Document

  • Client/Store Details

  • Technician Coverage Management

  • And several outdated mobile/job actions


Bug Fix

  • Fixed an issue where rotation % did not reset properly when job coverage was changed. The system now correctly recalculates ratio and rotation %.


Questions?

If you need help with any of these updates, please reach out to our support team.

Resolved

October 31, 4:13pm

October 31, 4:13pm

These updates are live.