November 2nd Release Notes

Informational
November 17, 10:47am

November 2nd Release Notes

Status: closed
Date: October 31, 4:13pm
End: November 17, 10:47am
Duration: 16 days 19 hours 34 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

October 31, 4:13pm

October 31, 4:13pm

CX Portal – Enhanced Security & Login Flow

A major update has been deployed to improve security, usability, and access reliability for the CX Portal.

Previous Flow

  • Login available only via Email.

  • OTP required if verification was older than 30 days.

What’s New

Multiple Login Options

  • Users can now log in via Email & Password or OTP.

  • OTPs are sent via both Email and SMS.

Smarter Token Management

  • Access tokens now have a 15-minute validity for higher security.

  • Tokens auto-refresh for 30 days (configurable by tenant).

  • Expired or invalid tokens redirect users to the login screen.

Simplified First-Time Access

  • New users receive a Welcome SMS with a secure token-based link for one-click access.

Device & Session Intelligence

  • OTP required when accessing the portal from a new device or after 30 days.

  • OTP requests have a 2-minute cooldown, with a 30-minute temporary block after 3 failed attempts.

  • PF users can now reinvite customers via a new “Send Invite” button in client profiles.

Seamless Access

  • Valid login sessions continue without interruption; expired sessions prompt re-login.

  • Customers can now set or update passwords directly from their profile.


New Widgets – Photo Upload Tracking

Track total and mobile-specific photo uploads per project using new widget columns:

  • Total Photo Count

  • Mobile Photo Count

This provides full visibility into media activity across web and mobile.


Quoting Module – mVendor % Logic Enhancement

Previous Behavior: Changing the mVendor % recalculated Retail Amount.
New Behavior: Adjusting the mVendor % now updates Revenue, keeping Retail Amount static.
All dependent totals (Labor, Product, Quote, Profit, Margin) update dynamically.

New summary fields added:

  • Total Profit = Total Revenue – Total Cost

  • Total Margin = (Total Revenue – Total Cost) / Total Revenue


Email Template Configuration – Store & Customer

Users can now configure automated emails to reach:

  • Customers, Stores, or Both, using a new multi-select “Send To” dropdown.

  • For stores, all email addresses marked “Send Email: Yes” will automatically receive the messages.


CRM Enhancements – Improved Visibility

Significant upgrades in Client, Opportunity, and Quote modules for better data management and tracking.

Client Profile

  • New fields: Client Source and Client Referral Source (visible on Opportunities & Quotes).

  • “Company Size” field now supports numeric ranges, exact values, or descriptive options.

Opportunities (Previously Leads)

  • “Lead” renamed to Opportunity throughout all forms, widgets, and reports.

  • Ownership tracking and assignment widgets now mirror the Projects module.

  • Audit Trails added for:

    • Owner changes

    • Status updates (with notes)

  • Metadata now includes Created By, Created Date, and Opportunity Found By.

  • New fields:

    • Estimated Opportunity ($)

    • Opportunity Temperature (Cold/Warm/Hot)

  • Archived Opportunities are now managed under a dedicated tab, hidden from active views.

Quotes

  • Added Quote Temperature field (Cold/Warm/Hot).

  • All new fields are exposed to widgets for performance tracking.


User Management – Retainage & Chargeback Summary

A new summary view under User Management displays:

  • Total amount, paid amount, and balance for each user’s Retainage and Chargebacks.


Calendar Enhancements

  • Technician names are now visible on Time Off and Block Time cards.

  • Improved at-a-glance visibility and identification.


Client Details – Quick Edit & Improved Access

Users can now view and manage:

  • Client emails and phone numbers directly on the main page.

  • Site addresses are now editable with a single click.


Chargeback Menu Relocation

  • “Add Chargeback” moved from Admin to Project Menu for faster access.

  • Permissions can now be managed directly under the Project Module.


Item Master – Independent Configuration & Inventory

Configuration and inventory settings are now separated:

  • Pencil icon: opens Item Configuration.

  • Inventory icon: opens Inventory Management.

  • Both editable independently, regardless of inventory flag.


Rotation % Simplification

When assigning or editing jobs:

  • System prompts to Auto Distribute or Skip rotation setup.

  • Admins can manually apply equal distribution at Store, Type, or Category levels.


Calendar Scheduler – Beta Version

The new Beta Scheduler offers:

  • Persistent technician positioning.

  • Standardized card layouts (top three fields defined by company config).

  • Optimized performance for large data volumes.


Mobile App – Extended UI/UX Performance

Performance and design improvements now cover:

  • Dashboard

  • Projects

  • EPA Lead sections


FCB2B Integration – Vendor Communication

A new add-on feature enabling end-to-end EDI vendor connectivity for:

  • Purchase Orders, Catalogs, Invoices, and Shipments

  • Includes Advanced Filters, Favorite Items, and Order Workflows via EDI 832/850/855/856/810 protocols.

Tenants can enable this integration by contacting PF360 Support.


Bug Fixes

  • Fixed: Non-technicians appearing in Related Technicians dropdown.

  • Fixed: Document count errors for unauthorized projects.

  • Fixed: Linked Labor prices not visible in FE-Mobile.

  • Fixed: Missing existing clients in New Project layout.

  • Fixed: Job status not updating after drag-and-drop in Scheduler.

  • Added: Created Date column in Task Listing.


End of October 2025 Monthly Release Notes

Resolved

November 17, 10:47am

November 17, 10:47am

These updates are live.