ProjectsForce 360 Nov 23 Release Notes
ProjectsForce 360 Nov 23 Release Notes
November 21, 8:18am
November 21, 8:18am
V IMP : Pin Based Login
We have upgraded the authentication system with Refresh Tokens and a new PIN-based quick login. Below are the key improvements:
1. Modern Session Management (Access + Refresh Tokens)
Access Token: short-lived session.
Refresh Token: long-lived session (replaces the old, 24-hour auto logout).
If refresh token expires or is missing → user must log in with Email + Password.
2. PIN (4digit) for Daily Login
Users can set an PIN after password login.
PIN is securely stored (hashed).
PIN changes/resets require password authentication.
3. Updated Login Scenarios
First Login / Refresh Token Expired → Email + Password required.
Daily Login (refresh token active) →
If PIN exists → login via PIN.
If PIN not set → login via Password, with a “Remind Me Later” option for 7 days and can be configured at tenant level.
3 Wrong PIN Attempts → PIN blocked → Password required.
3 Wrong Password Attempts → Account locked (admin unlock required).
Forgot PIN → Authenticate with Password → Set new PIN from settings.
4. Security & Behaviour Changes
OTP revalidation (every X days) removed.
PIN works only if refresh token is valid.
Password change does NOT auto-reset PIN.
Forgot Password resets only the password; PIN remains unchanged unless user chooses to update it.
5. Quick Journey Examples
Next-day login with PIN → Enter PIN → Success.
Next-day login without PIN → Use Password.
Refresh token expired → Password login needed.
Wrong PIN ×3 → PIN disabled until password login.
Summary
Password = fallback authentication.
Refresh Token = primary session key.
PIN = fast daily login (valid only while refresh token is active).
Strict security thresholds:
3 wrong passwords → lock
3 wrong PINs → PIN disabled until logged in with password
New Permission – “Year Built (Modify)
A new permission “Year Built (Modify)” has been added under:
Project → Project Details → Year Built (Modify)
This permission controls the ability to edit the “Year Built” field within the Project module (applicable to both Old and New Project layouts).
Users with this permission can modify the Year Built field.
Users without this permission will only have view access — they can see the value (if present) against each job but cannot modify it.
By default, this permission has been granted to all roles.
This enhancement ensures finer control over project information management and prevents unintended data changes.
Retainage and Chargeback Enhancements
1. Chargeback Handling for “Collect from Retainage”
When a Chargeback is marked as Collect from Retainage, it will now be reflected directly on the Retainage screen.
Display formula updated:
Retainage Balance = Total Retainage Amount – Total Chargebacks (Collect from Retainage)This is a display-only update; no database changes will be performed.
2. Retainage Calculation Accuracy (Bug Fix)
Incorrect retainage amount display issue has been fixed.
3. Retainage Editing Rules
After any payout has been processed, users can only edit the Total Retainage Amount.
Negative balances caused when Chargeback > Retainage are automatically handled within the new display logic (covered under Point 1).
4. Chargeback Editing Rules After Payouts
If a Chargeback's payout status is open, users can edit only the Chargeback amount.
Any adjustment will be applied to:
The last payout, or
A new payout, depending on the scenario.
5. Technician Deductions
Fixed issues preventing users from adding or editing technician-related payment deductions.
6. Applying Chargeback Balance to Retainer
Introduced functionality to apply remaining Chargeback balances directly to a retainer.
Copy Icon and Note Preview
The system will add a copy-to-clipboard icon next to the Notes description under Project → Communication. For long notes, a pop-hover with a scrollbar will appear, allowing easy reading of the full content sent by the other users.
Site Address Field Enhancement
To improve accuracy and clarity in address entry, the Site Address field has been redesigned and broken into multiple structured fields, similar to the Client Billing Address.
What’s New
Site Address is now captured using separate fields:
Street Address 1, Street Address 2, City, State, Zip Code.Users can now clearly specify apartment numbers, floor details, or additional site information in Street Address 2.
Why This Change
Reduces address ambiguity.
Improves data consistency across the platform.
Makes site-level details more precise for operations and reporting.
Make billing address as Editable
In cases where the client address is pulled from sources or newly created for private businesses, users often need to modify the billing address in the client basic profile, which is currently not allowed. Going forward, users can click the Edit button to modify the address and other client details.
Sort and filter on Site Listing page
In the client profiles' Sites section, where users add multiple site addresses with qualifying names, the system will add search and sort icons to the listing table. This will help users find sites by name, address, modifier, date, and more.
Copy Icons on New Layout
The system will add copy-to-clipboard icons to most fields in the new layout, such as client name, address, customer, and store fields. This allows users to copy data with a single click.
Refunded Jobs on Calendar
Some tenants want to see jobs with Refunded status on Calendar, Scheduler, and Map, while others do not. To address this, the system introduces a tenant-based company configuration to control refunded job visibility.
A new toggle, Show Refunded Jobs, will be added in Admin → Configuration → Scheduling & Assignment → Scheduler → Configure.
This toggle is enabled by default for all tenants, who can adjust it as needed.
Quote & Invoice Custom Layout
Currently, the CRM module (Quote and Invoices) has predefined templates and columns for Item details under Summary, Details Internal, and Details Customer. As an enhancement, the system now allows tenant admins to set custom layouts to display required fields on Quotes and Invoices. Once configured, a new option, Custom Layout, appears under the Send, Preview, and Download buttons. This custom layout, if configured is also the default for customer emails regarding approval and communications.
To configure this, tenants see two new options: Quote Custom Layout and Invoice Custom Layout under Admin → Configuration → Visual Enhancements. Clicking the configure button lets admins view all available options for Quotes and Invoices, selecting columns and their sequence.
Users can configure custom layouts separately for Quotes and Invoices. The Custom Layout option appears when creating new quotes or invoices only after configuration.
Rename RTS Follow Up Date
The system will globally rename the project-based RTS Follow Up Date to the generic field Follow Up Date, across the old and new project layouts, existing widgets, and more.
Decline Lead – New Action for Home Depot Jobs
Added a new “Decline Lead” action button (permission-based) for all Home Depot jobs.
Clicking the button opens a pop-up with:
Decline Reason (mandatory)
Note (optional) with a “Send to Source” toggle, ON by default
If ON → Note is sent to the source and added as a Retailer Note
If OFF → Note is added as an Internal Note
Upon confirmation, the job status will be updated to Cancelled, and the corresponding rules will be triggered.
Template-to-Project Document Shortcut
You can now create a project document directly from the template card using the new Create Project Doc button. If no edits are needed, simply click the button, preview the document, and confirm—no more navigating to the document screen.
The original conversion flow remains available.
Note: The button is hidden for templates that require signatures
Expose Columns on Widgets
Invoice all important columns to Project and Invoice table
Photo Category to Project Table
Site Name, Address and Contact to Project Table
Client contact details on Leads Table
Timezone Changes
To maintain consistency throughout the application and synchronize the timezone with the client timezone in their company profile, each release gradually corrects this. This release covers the following modules:
1. Admin: Warehouse, Labor profiles, Stores modules
2. Admin: dashboards, widgets, document center modules
3. Admin: Event logs, configuration, checklist modules
4. Project: Add Client Module
Bug Fixes
EPA Lead Details Handling
Enhanced handling for Lowe’s jobs where EPA Lead Test Response Reason = Presumed Lead.
The system now correctly processes scenarios where certain EPA-related fields selected as N/A.
Personalized Project Number Retention Issue
A bug will be fixed where the system retained a personalized project number on the browser tab, even when the job was not created.
Merge Client Pop-Up UI
Fixed a UI issue where the Merge Client pop-up did not render consistently.
Busted Technician – Labor Amount Calculation
A bug will be fixed where, for busted jobs, if the same technician was assigned again, the labor amount still appeared under the Schedule Info technician entry.
Invoice Due Date Mismatch
The discrepancy between Invoice Details and the Invoice Listing page due dates will be resolved.
Project Notes Sorting
Project notes are now correctly sorted by Created At (latest on top) for improved readability.
Widget Back-Button Navigation
A bug will be fixed where the widget back button redirected users to the default dashboard, instead of returning them to the dashboard from which the widget report was opened.
Client Creation Without Email
Fixed an issue where users were unable to create a client without an email address.
Added an asterisk to the Phone Number field to indicate it is mandatory.
Additional Fields Tab – New Layout
A bug will be fixed where the Additional Fields tab in the new project layout could not be modified.
Excessive OTP Emails
Issue identified where OTP emails were being triggered every time a mobile user logged in via email & password. A fix will be applied to prevent unnecessary OTP notifications.
December 21, 8:33am
December 21, 8:33am
These updates are live.