ProjectsForce 360 December 21, 2025 Release Notes

Informational
January 23, 8:37am

ProjectsForce 360 December 21, 2025 Release Notes

Status: closed
Date: December 21, 8:33am
End: January 23, 8:37am
Duration: 33 days 4 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

December 21, 8:33am

December 21, 8:33am

Technician Recommendation & Route Optimisation

ProjectsForce is releasing a new feature to automate scheduling by recommending the best technician for each job. It also helps the scheduling team view and optimize technician routes to minimize travel and maximize job coverage. To get this feature enabled, please reach out to our support team.

For technician recommendations, a new icon will appear on the RTS table. Clicking it displays technician recommendations based on job assignment coverage, including work schedule, job coverage, rotation %, service time, and capacity.

image-20251219-080141.png

The system recommends the best available technician and time slots. This ensures optimal selection based on technician availability without disrupting the existing workflow.

image-20251219-080307.png

For scheduled jobs, we will add a new icon next to each technician on the calendar. This icon opens a routing screen showing all the technician's scheduled jobs on the map with arrival times, calculated from travel distances between start and end locations and each job's service time. The map displays all scheduled jobs and an optimized route using Google's real-time algorithm. Users can rearrange jobs by dragging and dropping or add more jobs from available unassigned tasks within the technician's coverage area.

image-20251219-080814.png
image-20251219-080847.png 

Once the user analyzes the optimized sequence and route, they can confirm it in the system. The system will update the job's arrival start and end times on the jobs and, if SMS is configured by the tenant, notify customers of the arrival slots.


CRM Sales KPI Widgets

The system is adding new widget tables, starting with KPI -, to set up multiple CRM widgets for tracking company sales. Company owners can view the turnaround time between two dynamic opportunity statuses, assess sales team performance, and analyze MRR by company size and sources. Using these KPI tables, users can set up the following widgets as needed:

Strategic/Leading Indicator

  1. Client → Opportunity Conversion rate

  2. Opportunity → Quote conversion rate

  3. Quote → Project Conversion rate

  4. Customer Segmentation Visibility

  5. Stage Velocity

Funnel & Pipeline

  1. Lead Volume

  2. Lead to Qualified conversion %

  3. Demo-to-Opportunity Conversion %

  4. Opportunity-to-Close Conversion % (Win Rate)

  5. Pipeline Value by Stage

Sales Efficiency

  1. Average Deal Cycle Length

  2. Average Deal Size Based on Company Size (ACV / MRR)

  3. Contact-to-Opportunity Rate

Revenue & Forecasting

  1. New ARR / MRR

  2. Revenue by Segment

  3. Revenue by Channel

  4. Open Quotes $ Value

Retention & Expansion

  1. Churn Rate %

CRM : Qualified / Unqualified Feature

To segregate genuine Opportunities, the system will add a toggle labeled Qualified, to each CRM Opportunity (off by default). Once the salesperson or Opportunity owner contacts and validates the customer, they can enable this toggle, which records the user, date, and time.

Once marked qualified, an opportunity cannot be reverted.

This flag will appear on the listing page and in widgets (Projects and Opportunity table) for reference and reporting.

image-20251218-062930.png
image-20251218-074205.png
image-20251218-074236.png
image-20251218-074302.png 

Chargeback and Retainage Enhancements

  • Chargeback Clone Feature
    Added the ability to clone the chargeback directly to the system for easy reference, on Project and general chargeback

  • Order-Level Chargeback Flag
    Orders can now be clearly flagged to indicate the presence of an unpaid chargeback with a count on the tab.

  • PO Number for Chargebacks
    Under Admin → User → Retainage Module → User Chargeback, a hyperlinked PO Number can now be added while creating a new chargeback for better traceability.

  • Automated Authorization Number for Chargebacks
    Introduced automation to generate an authorization number (First 3 Letter of Workroom + 4 digits of random number) as Chargeback # and share it with retailers via a retailer note, without requiring manual note entries. (** To enable the feature to send retailer notes to source, please connect with our Support team).

Timeline (Project and Client Based)

ProjectsForce will roll out a new feature called Timeline in two modules, allowing users to view all communication related to a job or client in one place.

Project Based Timeline:

A new permission-driven tab named Timeline, will be added under Project. It will display all communications—SMS, Email, and Notes—grouped by each Related PO of the job, providing a single view for users to see and communicate as needed.

image-20251218-115154.png

A tenant-based configuration, Group POs Under Same Project is added under Project Management & Linkage → Timeline Communication. When selected, the Timeline tab in each project of that tenant displays communications for the same client and project number across different POs. Users can check or uncheck this option at runtime under project to override the default tenant settings.

image-20251218-115005.png
image-20251218-114926.png 

Client Based Timeline

Under each client profile, a new tab named Communication will combine Notes, SMS, and Email. Each tab will display all communications with that client at the client level, CRM (Opportunity, Quote, Invoice), or any Project level.

The system will pull all communications sorted by date, with a reference column showing each communication's linkage.

image-20251218-114419.png

Separate Bio Details for Calendar and Customer Portal

Under user management → user profile, the Bio details field describes a user's professional information. Tenants use this to display on Scheduler cards, and customers see it on the Customer portal. To separate internal technician skill set from customer-facing details, the system will split this into two fields:

Calendar Bio Details and CX Portal Bio. These control what the internal team and end customers see, respectively. The new field appears only if the tenant has enabled the Customer Portal feature and includes a copy icon to transfer content as needed.

image-20251218-131250.png

Show Labor, Product and Linked Items on Template & Document Preview

Like the view users see when opening documents or templates, this view will now appear on the preview screen. Users no longer need to repeatedly click the Edit button to see all required details on the document preview.

image-20251218-131606.png

Project Billing tab Enhancements

The system will enhance the Project Billing tab UI by dividing it into sub-tabs for better user experience and data visibility.

The Payment Requests tab will display all PR details from sources (Lowes / Home Depot).

The Invoices and Bills tab will show invoice and bill details created on Quickbooks by the tenant using ProjectsForce.

Note: CRM-based invoices will appear on a separate tab Invoices. All tabs are permission-controlled; update roles as needed.

image-20251219-083801.png

Global Filters: Assign to Dashboard Checkbox

Under user management → Global Filters, the tenant admin sets default or multiple filters for any company user to control what they see on the scheduler calendar and in global filters. The system will add a new checkbox on the filters listing page labeled Apply To Dashboard, which enforces these filters on the dashboard, limiting data shown on widgets to the user.

image-20251218-132537.png

Bug fix for Auto distribution of Rotation %

The system will exclude inactive users from auto-distribution when allocating rotation percentages and will omit non-technician users (those without Installer View permission) from the Rotation % tab breakdown to prevent confusion.

Resolved

January 23, 8:37am

January 23, 8:37am

These updates are live.