Important Upcoming UI Change

Informational
February 06, 7:58am

Important Upcoming UI Change

Status: closed
Date: January 23, 8:38am
End: February 06, 7:58am
Duration: 13 days 23 hours 20 minutes
Affected Components:
Home Depot Lowe's IMS Dynamic Widgets ProjectsForce Android Mobile App ProjectsForce iOS Mobile App Email Service ProjectsForce SMS Service
Update

January 23, 8:38am

January 23, 8:38am

Introducing the Next Evolution of ProjectsForce 360

Modern UI Rollout Begins February 8

At ProjectsForce 360, we believe great software is never static. It should evolve alongside your business, continuously improving how you work, how you see your data, and how efficiently your teams operate.

On February 8, we are introducing a new modern user interface designed to elevate usability, clarity, and performance across the platform while laying the groundwork for future innovation.


A Thoughtful Transition Built Around You

We recognize that change is best adopted when users have time to adjust. With that in mind, this release will follow a phased transition approach:

  • February 8: The new modern UI becomes available as an optional experience
  • A toggle button will be visible within the application, allowing you to switch between:
    • The new Modern View
    • The existing Classic View
  • 30-day transition period: You can move between views at your own pace

After the 30-day transition window:

  • The Classic View will be retired
  • All users will be fully transitioned to the new Modern UI

This approach ensures continuity, minimizes disruption, and gives your teams time to explore and adopt the updated experience with confidence.


Why We’re Making This Change

This UI update is not just a visual refresh. It represents a strategic investment in:

  • A cleaner, more intuitive navigation experience
  • Stronger consistency across the entire platform
  • Improved data visibility and interaction
  • A modern foundation that enables faster feature delivery moving forward

Most importantly, it reflects our commitment to ensuring that the platform you’ve invested in continues to move forward and never feels stagnant.

 

What to Expect Next

During the transition period, we encourage users to explore the Modern View and begin incorporating it into daily workflows. Additional enhancements will continue to build on this new foundation in upcoming releases.

As always, your feedback matters. This evolution is driven by our customers, and we remain fully committed to delivering a platform that grows with your business.

Thank you for partnering with ProjectsForce 360. We’re excited about what’s ahead.


New Sidebar Menu and Navigation:


New Bar Charts With Color Coding and Values On Each Bar. 


New Comparison Widgets:


New Gauges to Show Comparisons:


Simplified Role and Permission Management:

Resolved

February 06, 7:58am

February 06, 7:58am

These updates are live.